We're here to help.

Tablets

We support devices that have the A9 processor or newer in order to ensure that your imaging experience will suit your clinical needs and as a result iQ won’t work on the older iPad mini.

Supported devices (Lightning):

  • iPad 5th gen
  • iPad 6th gen
  • iPad Pro 12.9" 1st or 2nd gen
  • iPad Pro 9.7"
  • iPad Pro 10.5"
  • iPad mini 5th gen
  • iPad Air 3rd gen

Support devices (USB-C):

  • iPad Pro 12.9" 3rd gen
  • iPad Pro 11"

Apple iOS 11.0 or newer.

 

 

Was this article helpful?
3 out of 3 found this helpful
Thank you for your feedback

We’re sorry this didn’t answer your question. We’re here to help. Contact us